Sådan løser du problemer med iTunes 10 og Automator

Apples iTunes 10 er komplet inkompatibel med Automator, men der er en løsning.

Hvis du bruger Automator sammen med iTunes har du sikker bemærket at det ikke er muligt med den nye iTunes 10.

Det skyldes måde, Automator læser dine scripts på. Automator benytter nemlig Apple Scripts og tester ved opstart versionsnummeret som teksstrenge og det gør version 10.0 til at lavere nummer en version 9.2.1.

Mac OS X Hints har heldigvis fundet en simpel løsning på problemet.

  1. Gå til /System/Library/Automator.
  2. Kopier alle de scripts der har at gøre med iTunes ud på dit skrivebord
  3. Herefter skal du højreklikke på dine scripts og vælge  ”Vis indholdet af pakke”.
  4. Åben derefter filen Info.plist  der ligger i mappen Contents.
  5. Find følgende tekst og slet det, og husk også at gemme bagefter:

<key>Version</key>
<string>4.6</string>

Herefter importerer du dine filer tilbage i Automator.

Før du begynder bør du læse instruktionerne hos Mac OS X Hints.

© 2010, maczonen.dk. All rights reserved.

Add a Comment

Din e-mailadresse vil ikke blive publiceret. Krævede felter er markeret med *

This site uses Akismet to reduce spam. Learn how your comment data is processed.